В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Zara2217
Zara2217
21.03.2023 06:51 •  Информатика

Составьте схему алгоритма и напишите программу для вычисления значения функции y.

Показать ответ
Ответ:
Jenya19885
Jenya19885
04.01.2023 02:02

USES CRT;

VAR m1,m2,n,n1,n2,n3,n4,n5,n6,s1,s2:LongInt;

BEGIN

ClrScr;

     ReadLn(n);

  m1:=n;

   n1:=m1 div 100;

   n2:=m1 mod 10;

   n3:=(m1-n1*100-n2) div 10;

 if n1=n2 then if n1=n3 then writeln('vse =');

 if n1=n2 then writeln('1 i 3 =');

 if n2=n3 then writeln('2 i 3 =');

 if n1=n3 then writeln('1 i 2 =')

 else writeln('<>');

 END.

Проверяйте, что непонятно - спрашивайте.

Можно чуть поправить вывод, чтобы когда vse =, не вылезали 1 i 3, 1 i 2, 2 i 3.

Да и вообще writeln'ов можно наставить и переменные назвать покрасивше. но это уж вы сами, думаю, справитесь. В VAR у меня тоже есть лишние переменные, переделывал старый свой код наспех =)

Всего хорошего.

0,0(0 оценок)
Ответ:
SlavaPereli
SlavaPereli
19.08.2022 02:02
1. Теория хаоса тебе в т. к. на счёт этого ты должна сама подумать.
2. До сборки - Да. Любое устройство в компе ожидает входные данные, дальше как то их обрабатывает и выдаёт обратно, алгоритмы обработки обсалютно разные для каждого устройства (жёсткий, оперативка, bios)
После - тем более да, так как без системы каждый элемент компа бессмыслен и бесполезен. Каждый из них дополняет друг друга.
После включения - да, вся система начинает реагировать как то и отвечать (выходные сигналы - принтер, экран, вибрация на джойстике, загорается лампочка на камере когда идёт чтение видео с камеры)
3. Свойства зависят от внутренних параметров каждого компонента. На примере компа - частота процессора обеспечивает с какой скоростью обрабатываются данные, оперативка - сколько памяти храниться в ней для быстрого вызова и передачи на процессор, на жёстком его объём и скорость чтения/записи.
Каждый компонент важен в системе, есть ключевые (процессор, опертивка) от которых многое зависит, а есть не особо зависимые параметры компонета (объём жёсткого) . И т. д. и т. п. Надеюсь дал более менее развёрнутый ответ.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота