В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составьте программы на паскале по алгоритмам из 3,4 предыдущего параграф. выполните эти программы на компьютере 4 из предыдущего параграфа : вы посетили магазин и купили 10 видов товара.в таблицу t[1: 10] вы записали количество купленного товара каждого вида.в таблицу c[1: 10] записали цены единиц каждого вида товара соответственно.составьте алгоритм вычисления общей стоимости всех покупок. 3 из предыдущего параграфа : вопрос для тех же исходных данных,что рассматриваются в параграфе,составьте алгоритм,в котором вычисляются четыре величины: средние температуры зимних месяцев,весенних месяцев ,летних,осенних месяцев.

Показать ответ
Ответ:
DarKerThanBlaCK34
DarKerThanBlaCK34
29.05.2020 03:32

Программа:

{Free Pascal Compiler version 3.0.4+dfsg-23 [2019/11/25] for x86_64}

{Copyright (c) 1993-2017 by Florian Klaempfl and others}

{Target OS: Linux for x86-64}

program test;

Uses Math;

   var

       A : array of integer;

       N, S, i : integer;

begin

   Randomize;

   S := 0;

   write('Укажите длину последовательности: ');

   Readln(N);

   {Генерация и печать массива}

   SetLength(A, N);

   for i := 1 to N do begin

       A[i] := Random(50);

       write(A[i], ' ');

       end;

   writeln; writeln('------------------------------');

   for i := 1 to N do

       {Определение кратности элемента массива числу 5}

       if A[i] mod 5 = 0 then begin

           {Вывод на экран этого числа}

           write(A[i], ' ');

           {Подсчет суммы чисел}

           S := S + A[i];

           end;

   writeln;

   {Вывод на экран суммы}

   writeln('Сумма - ', S);

end.

Объяснение:

Программа просит ввести пользователя число, длину генерируемой последовательности. Затем создается массив нужной длины, заполняется значениями от 0 до 50. Затем во втором цикле просматривается каждый элемент массива, - если он кратен 5, то число выводится на экран и суммируется.

В конце программа выводит итоговую сумму найденных элементов.

Результат выполнения программы:


Дана последовательность из n-целых чисел. Найти сумму всех чисел кратных 5. На языке Паскаль​
0,0(0 оценок)
Ответ:
gggggggx
gggggggx
03.01.2020 16:05

import turtle

from math import tan, sqrt, pi

def prepare(x, y, color):

   turtle.penup()

   turtle.goto(x, y)

   turtle.pendown()

   turtle.color(color)

   turtle.begin_fill()

def draw_polygon(num_sides, side_length):

   angle = 360.0 / num_sides

   for i in range(num_sides):

       turtle.forward(side_length)

       turtle.right(angle)

   turtle.end_fill()

def calc_s(num_sides, side_length):

   return num_sides * side_length ** 2 / (4 * tan(pi/num_sides))

def calc_side(square):

   return sqrt(4 * square * tan(pi/num_sides) / num_sides)

turtle.hideturtle()

turtle.speed(10)

colors = ['red', 'green', 'blue', 'cyan', 'magenta', 'black', 'yellow', 'pink', 'brown']

xcoords = [0, 150, -150, 150, -150, 270, -270, 270, -270]

ycoords = [0, 150, -150, -150, 150, 270, -270, -270, 270]

squares = []

numsides = []

for i in range(9):

   num_sides = i + 3

   square = round(calc_s(num_sides, 100), 2)

   side_length = round(calc_side(10000), 3)

   squares.append(square)

   numsides.append(num_sides)

   print("Углов:", num_sides, "была площадь:", square, "стала длина грани:", side_length,

         "изменение в", round(side_length/100, 2), "раз")

   prepare(xcoords[i], ycoords[i], colors[i])

   draw_polygon(num_sides, side_length)

turtle.exitonclick()

print("Список количество углов:", numsides, end="")

print("Список площади:", squares)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота