В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ulia09200413
ulia09200413
05.12.2022 15:32 •  Информатика

Составьте программу заполнения массива а числами фибоначчи. в последовательности фибоначчи значения первых двух элементов равны 1, а значение каждого последующего элемента, начиная с третьего, равно сумме двух предыдущих. индексы элементов 1 2 3 4 5 6 7 8 9 10 значение элемента 1 1 2 3 5 8 13 21 34 55

Показать ответ
Ответ:
лилька123
лилька123
02.10.2020 02:30
Program gt;
var a:array[1..10]of integer;
i:integer;
begin
a[1]:=1;a[2]:=1;
write(a[1],' ',a[2],' ');
for i:=3 to 10 do
begin
a[i]:=a[i-2]+a[i-1];
write(a[i],' ');
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота