В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
KatyaD2005
KatyaD2005
31.07.2020 19:14 •  Информатика

Составьте программу записывающую в файл одномерный массив случайных чисел, а затем считывающую его с диска и выполняющую запись четных элементов в другой файл (на паскале)

Показать ответ
Ответ:
baekksas
baekksas
27.07.2020 12:26
Program untitled;
var t,t2:text;
    i,a:integer;
    m:array [1..50] of integer;
begin
randomize;
assign(t,'output.txt');
assign(t2,'output2.txt');
rewrite(t);
 for i:=1 to 50 do begin
 m[i]:=random(50);
 writeln(t,m[i]);
end;
 reset(t);
rewrite(t2);
for i:=1 to 50 do begin
 readln(t,a);
 if a mod 2=0 then
  writeln(t2,a);
 end;
 close(t);
close(t2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота