В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
паша535
паша535
07.02.2022 11:15 •  Информатика

Составьте программу замены нулевых элементов таблицы единицами контрольный пример n=5 данные : (0,5,0,60,0) результат : (1,5,1,60,1)

Показать ответ
Ответ:
Язык Pascal, работа на массиве. с заполнением с клавиатуры. Ты заполняешь 5 элементов ( через enter ), а он тебе выводит тоже самое, только с однерками вместо нулей.

Var x: array[1..5] of integer;
Var i,h:integer;
Begin
for i:= 1 to 5 do
Begin;
Readln(h);
if (h=0) then x[i]:=1 else x[i] = h;
end;
for i:=1 to 5 do
Begin;
Writeln('Элемент номер ',i,' массива: ',x[i]);
end;
readln(x);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота