В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kiska510
kiska510
07.11.2022 12:09 •  Информатика

Составьте программу вычисления выражения (разными применяя каждый из операторов while,repeat,for) a^p, где p - целое число. pascal / надо.

Показать ответ
Ответ:
KINGAsyaKING
KINGAsyaKING
04.08.2020 10:00
1)Это с

var a,p,i,c:integer;
begin
  readln(a);
  readln(p);
  c:=1; i:=0;
  while i<p do
  begin
    c:=c * a;
    inc(i);
  end;
  writeln(c);
  readln;
end.

2) Это с

var a,p,i,c:integer;
begin
  readln(a);
  readln(p);
  c:=1; i:=0;
  repeat
    c:=c * a;
    inc(i);
  until i=p;
  writeln(c);
  readln;
end.

3) Это с

var a,p,i,c:integer;
begin
  readln(a);
  readln(p);
  c:=1;
  for i:=1 to p do
    c:=c * a;
  writeln(c);
  readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота