В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составьте программу вычисления в массиве b максимального среди отрицательных элементов и его номера.

Показать ответ
Ответ:
BTS111111y
BTS111111y
08.10.2020 10:33
Var i,N,max,k:integer;
B:array[1..N] of integer;
begin;
writeln('Сколько элементов в последовательности?');
readln(N);
writeln('Введите элементы массива');
for i:=1 to N do 
begin
readln(B[i]);
if B[i]>max then
begin 
max:=B[i];
k:=i
end;
writeln('Наибольший элемент последовательности = ',max,'. А его порядковый номер ', k);
end.
0,0(0 оценок)
Ответ:
76676556586
76676556586
08.10.2020 10:33
Const k=30;
var
b,a:array [1..k] of integer;
i,m,n,k1:integer;
begin
for i:= 1 to k do
b[i]:= Random(-15,15);
writeln(b);
for i:=1 to k do
if (b[i]<0) then
begin
m:=b[i];
n:=i
end;
for i:=1 to k do
if (b[i]<0) and (b[i]>m) then
begin
m:=b[i];
n:=i
end;
for i:=1 to k do
if (b[i]<0) and (b[i]=m) then
begin
k1:=k1+1;
a[k1]:=i
end;
writeln ('Максимальный отрицательный элемент ',m);
if k1>1 then
for i:=1 to k1 do writeln ('Номер максимального отрицательного элемента ',a[i])
else writeln ('Номер максимального отрицательного элемента ',n)
end.

Пример:
[5,8,-11,4,-6,-3,-8,10,15,13,11,-2,0,-5,-14,11,-1,-7,15,-12,-11,5,-2,15,11,0,1,7,8,14]
Максимальный отрицательный элемент -1
Номер максимального отрицательного элемента 17

Пример:
[14,-4,5,-1,-14,4,-3,9,7,-15,1,9,11,-10,-1,4,1,-10,6,-13,-10,-5,1,9,9,-9,-7,-2,9,12]
Максимальный отрицательный элемент -1
Номер максимального отрицательного элемента 4
Номер максимального отрицательного элемента 15
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота