В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Konstantin11111
Konstantin11111
06.08.2021 13:07 •  Информатика

Составьте программу вычисления у по заданному х. y=-3х, х <0 х+5, x20
Пример входных данных
x=-5
X=2​


Составьте программу вычисления у по заданному х. y=-3х, х <0 х+5, x20 Пример входных данныхx=-5X

Показать ответ
Ответ:
iprin
iprin
13.08.2021 19:57
Const   n = 5; var   i: integer;   a: array[1..n * 2 + 1] of integer; begin   writeln('исходный массив: ');   for i : = 1 to 2 * n do   begin       a[i] : = random(99) + 1;       write(a[i] : 5);   end;   for i : = 2 * n + 1 downto n + 1 do       a[i] : = a[i - 1];   a[n + 1] : = 0;   writeln();   writeln('полученный массив: ');   for i : = 1 to 2 * n + 1 do       write(a[i] : 5); end.
0,0(0 оценок)
Ответ:
kristinakwai
kristinakwai
17.05.2021 10:19
Замечание надеемся, что вы еще не забыли о позиционном принципе записи чисел в любых системах счисления (значение цифр, количество которых ограничено, зависит от положения в числе, от ее позиции).в данный момент мы делаем шаг в сторону абстрагирования от конкретных значений цифр и начинаем считать только количество знакомест (позиций), которое в принято называть "разрядом", а совокупность разрядов (знакомест) — "разрядностью". определение разряд в арифметике — это место, занимаемое цифрой при записи числа. например, в десятичной системе счисления цифры первого разряда — это единицы, второго разряда — десятки и т. д. но арифметические законы, которые кажутся привычными в десятичной системе счисления, все без исключения действительны и для двоичной системы счисления. двоичные числа также можно складывать, вычитать, перемножать и делить с использованием тех же приемов школьного курса арифметики. отличие заключается только в том, что используются всего две цифры. кроме того, как мы уже выяснили, в двоичной системе счисления каждый разряд — это бит и его значение зависит от позиции и равно соответствующей степени числа "2". определение разрядность двоичного числа — это количество знакомест (разрядов) или количество битов, заранее отведенных для записи числа. пример десятичное число "2" может быть записано различными способами в зависимости от разрядности двоичного числа: как "10", если разрядность равна двум; как "0010", если разрядность равна четырем; как "00000010", если разрядность равна восьми. обратите внимание, что последний вариант соответствует записи десятичного числа "2" в пределах одного байта информации. разрядность двоичного числа интересует нас в связи с тем, что это количество разрядов (позиций или знакомест) обеспечивает определенный набор возможных двоичных чисел, которые, как мы уже договорились, могут служить , с которых происходит кодирование любых видов информации: собственно чисел, текстов, графических и цветных изображений, звуков, анимации и видео. осталось только выяснить, каким образом разрядность влияет на количество информации (двоичных кодов), котоую можно получить с определенного количества разрядов. однако прежде следует учесть одну особенность двоичных чисел, нашедшую применение в компьютерных технологиях, — это фиксированные значения разрядности двоичных чисел.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота