В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Pikasso07
Pikasso07
23.01.2022 23:14 •  Информатика

Составьте программу вычисления суммы повторяющихся элементов одномерного массива. (паскаль)

Показать ответ
Ответ:
Масим007
Масим007
26.08.2020 12:09
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-20,20); a.Println;
  Writeln('Sдубл=',a.GroupBy(c->c).Select(c->(c.Key,c.Count))
      .Where(c->c[1]>1).Select(c->c[0]*c[1]).Sum)
end.

Пример
n= 15
1 2 -10 18 8 -18 -8 -6 -11 -7 -10 -11 3 2 2
Sдубл=-36
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота