Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Chirtulova228
23.05.2021 03:17 •
Информатика
"составьте программу вычисления суммы элементов от первого отрицательного и до конца" (pascal abc)
Показать ответ
Ответ:
АнимешникИз2К17
03.07.2020 13:24
Var
mas:array[1..100] of integer;
i,n,sum:integer;
bool:boolean;
begin
bool:=false;
sum:=0;
readln(n);
for i:=1 to n do
begin
read(mas[i]);
if mas[i]<0 then
bool:=true;
if bool=true then
sum:=sum+mas[i];
end;
writeln(sum);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
kotflin
18.02.2020 08:05
1) Написать программу на языке Паскаль вычисления выражения:S = 4f^2-√25+12m №2 Написать программу на языке Паскаль вычисления выражения. В ответе должно быть не только число,...
dimkach2014
25.03.2022 05:06
1 вариант 2 задание не пойму и заранее...
inga20062
18.04.2021 09:03
Взаданном одномерном массиве, состоящем из n целых числел, подсчитать кол-во нулей блок схемой на...
shodruz28071998
03.08.2020 01:08
Хелп ми . в какой консерватории учился композитор: а) миланской б) венецианской в) парижской 8. а. вивальди мастер ансамблево-оркестрового концерта: а) филармонического б) дивертисмента...
xodocovp0a3a7
03.08.2020 01:08
Какие реформы были проведены в россии во второй половине 19 века ответ...
akhmedkhatataev95
03.08.2020 01:08
Он, этот земский авгур, населяет теперь все вагоны, все гостиницы. как подчеркнуть все ? (как обстоятельство, дополнение или определение? )...
matlis
03.08.2020 01:08
Тіло, що рухається прямолінійно рівноприскорено, за перші дві секунди пройшло 180 м, за другі дві секунди — 168 м у тому самому напрямі, за треті дві секунди — 156 м і т.д. визначіть...
KristheMalen
03.08.2020 01:08
Уподобных треугольников сходственные стороны равны 7 см и 5 см.площадь первого треугольника равна 27 см(в квадрате).найдите площадь второго треугольника....
straza982
03.08.2020 01:08
Решить. преобразуйте в смешанное число дробь: 1) 7/3 ; 2) 30/7. 2) найдите все натуральные значения х, при которых верно неравенство 2 целых 3/7 х/7 3 целых 1/7....
кирилл2434
03.08.2020 01:08
Разобрать по составу найти словосочетание в июньские жаркие дни девочки собирали в густой траве душистую землянику...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
mas:array[1..100] of integer;
i,n,sum:integer;
bool:boolean;
begin
bool:=false;
sum:=0;
readln(n);
for i:=1 to n do
begin
read(mas[i]);
if mas[i]<0 then
bool:=true;
if bool=true then
sum:=sum+mas[i];
end;
writeln(sum);
end.