В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Blaxi
Blaxi
01.03.2021 13:49 •  Информатика

Составьте программу вычисления произведения простых делителей натурального числа n.

Показать ответ
Ответ:
Казань565
Казань565
01.10.2020 12:54
var
x,i,n: integer;
begin
x:=1;
write('Введите натуральное число: ');
read(n);
write('Простые делители числа ',n,': ');
for i:= 1 to n do
 if n mod i = 0 then
  begin
  write(i:4);
  x:=x*i;
  end;
writeln;
writeln('Их произведение: ',x);
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота