Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Filindenis
28.03.2020 17:07 •
Информатика
Составьте программу вычисления функции y=sinx2^n используйте подпрограмму,функцию для ее вычисления
Показать ответ
Ответ:
Anna170806
04.10.2020 19:14
Var x,y:real; n:integer;
function f(x:real;n:integer):real;
var i,st:integer;
begin
st:=1;
for i:=1 to n do st:=st*2;
f:=sin(x)*st;
end;
begin
writeln('x, n:');
readln(x,n);
y:=f(x,n);
writeln('x = ',x,' y = ',y);
end.
Пример:
x, n:
2 5
x = 2 y = 29.0975176584218
0,0
(0 оценок)
Ответ:
Катюха1324
04.10.2020 19:14
Program sinus;
var x,y:real;
begin
writeln('введите число');
readln(x);
y:=sin(x)*2*2;
writeln(y);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Lovedashuta
18.08.2022 07:14
Задачи на системы счисления. Напишите следующие числа в развёрнутой форме:А) 1195,704810 Б) 111011012 В) 71258 Г) АFDЕ16Даны значения кодов для русских букв из стандартной...
Imdav88
13.05.2022 14:19
Каталог содержит информацию о , хронящихся Вместо многоточий написать соответствуйщие понятия. ...
ЛёхаТихонов
29.12.2021 01:40
Укажите адрес выделеных диапазоных ячеек ...
Каке11
09.07.2020 15:16
Лабораторная работа по информатике. v1 литров воды нагревается на электроплите от температуры t0 до температуры t1, а v2 литров- до температуры t2. сколько будет...
RassvetZaGorami
09.07.2020 15:16
Запишите условие поиска файлов, в имени которых встречается «z»...
vladir03Wlad
17.04.2020 22:54
Сколько целых положительных чисел удовлетворяет следующему условию (x 14) и ((x 8) или (x...
маша111221
05.02.2023 17:53
Напишите имена известных вам программ открывающие файлы со следующими расширениями: txt, doc, bmp, rtf, arj....
prostonick111237
20.01.2022 02:46
Что делатьесли выбивает : встречено else , а ожидался оператор, uses robot; begin task( if2 ); if wallfromright then; begin left; paint; down; right; paint; up;...
данил1780
04.11.2022 15:52
Составить блок-схему алгоритма для решения следующей ввести три числа, если сумма первого и второго больше 10, то вывести на экран сумму и произведение всех трех...
SuperChelovek
12.02.2020 20:25
Какая информационная модель более подходит, чтобы показать распо- ложение парт в классе? a) список b) схема c) словесное описание d) таблица...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
function f(x:real;n:integer):real;
var i,st:integer;
begin
st:=1;
for i:=1 to n do st:=st*2;
f:=sin(x)*st;
end;
begin
writeln('x, n:');
readln(x,n);
y:=f(x,n);
writeln('x = ',x,' y = ',y);
end.
Пример:
x, n:
2 5
x = 2 y = 29.0975176584218
var x,y:real;
begin
writeln('введите число');
readln(x);
y:=sin(x)*2*2;
writeln(y);
end.