В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
zlatoust99
zlatoust99
02.04.2021 01:26 •  Информатика

Составьте программу в среде КуМир для вычисления по приведённой ниже формуле

Показать ответ
Ответ:
Всенорм1111
Всенорм1111
19.05.2023 04:15

1) 1

2) 2

3) 2

4) 2

Объяснение:

1)

т.к.  выражение в информатике - запись про которую можно однозначно сказать, оно ложно или нет

2)

а) НЕ (Первая буква согласная) - Первая буква гласная

б) НЕ  (Последняя буква гласная) - Последняя буква согласная

ИЛИ - Одно из двух условий

ложно для имени - ни условие а), ни условие б) не выполняется

Пимен выполняет условие б)

Кристина не выполняет ни одно из условий

Ирина выполняет условие а)

Александр выполняет условие а)

3)

¬ - оператор НЕ

& - оператор И

В общем виде НЕ(условие 1) И НЕ(условие 2)

Выражение истинно если не выполняются оба условия

Условие 1: x < 6.

Условие 2: x < 7.

Искомое число больше чем 6 и 7. Минимальное целое - 8.

Из предложенных вариантов подходит только 9

0,0(0 оценок)
Ответ:
1234567891241
1234567891241
25.09.2020 18:39
Var 
a: array[1..8] of integer; 
i, b, min: integer;
begin 
b := 1; 
for i := 1 to 8 do  begin   
write('Введите ', i, '-ый элемент массива ');   
Readln(a[i]); //Вводим число
if i = 1 then min := a[i] else // Если это первое число то min:= это число   
if min > a[i] then begin //Если min оказывается больше введённого числа
min := a[i]; //то min:= это чило
b := i; //и переменной b := номер этого числа в массиве
end; 
end; 
Write('Первоначальный массив | '); 
for i := 1 to 8 do write(a[i], ' ');  // Выводим этот массив
Writeln('| Индекс минимального элемента ', b, '. Число ', a[b]); // Переменную b и элемент стоящий на месте b  
Write('Преобразованный массив| '); 
for i := 1 to 8 do   begin   
a[i] := a[i] - min;    //Преобразуем массив вычитая из элемента i - min
write(a[i], ' ');  // И сразу выводим преобразованное число
end; 
write('|');
end. //конец
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота