Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
SuperMax2003rus
05.04.2020 10:41 •
Информатика
Составьте программу в результате выполнения которой выясняется входят ли четные цифры в запись данного трехзначного числа. для паскаля
Показать ответ
Ответ:
rageworker
30.09.2020 03:54
Var a,a1,a2,a3:integer;
begin
write('a = ');
readln(a);
a1:=a div 100;
a2:=a div 10 mod 10;
a3:=a mod 10;
if (a1 mod 2 = 0)or(a2 mod 2 = 0)or(a3 mod 2 = 0)
then writeln('В числе есть четные цифры')
else writeln('В числе нет четных цифр');
end.
Пример:
a = 519
В числе нет четных цифр
0,0
(0 оценок)
Популярные вопросы: Информатика
Nessmikk13
30.05.2022 18:59
Что изображено? vvv v v ^ ^ ^^^ отвечайте если знаете...
FenrisYT
30.05.2022 18:59
В паскале построить график или что то типо того сделать уравнение y=tg(x-3)+4 хнач -3 хкон 3 дельта х 0.5...
frostdog0609
11.03.2022 17:22
Постройте ориентированный граф(рисунок) автомата Мура. Автомат, принимая на входе монеты 10; 15 и 20 коп., выдает сигнал П, если значение текущей сум-мы опущенных монет...
врошдщ
27.03.2023 03:34
C#: Описать структуру с именем TRAIN, содержащую следующие поля: • название пункта назначения; • номер поезда; • время отправления. Написать программу, выполняющую следующие...
gsgshhshsbababa
30.01.2023 15:03
Небольшая компьютерная фирма занималась продажей компьютеров с предустановленной нелицензионной версией операционной системы windows xp. она имеет легально закупленную...
ггвв
30.01.2023 15:03
Запиши свои размышления об природой плавательным средством собой- картина 9-ый вал...
котак5
30.03.2023 04:14
3D-модели объектов. Урок 4сферацилиндрторусполусфера...
BLACK2IVAN
02.02.2021 23:52
Тестлардан берэр дорес жавапны билгелэ...
Pelyovin1980
19.10.2022 06:06
1а)Заполните пропущенные слова в тексте(3). Эффективность дыхания определяется количеством молекул Так при анаэробном типе на выходе образуется молекулы, а при аэробном...
nastyabogatiko
19.10.2022 06:06
Автомобиль массой 750 кг начинает движение с укореняем под действием равнодействующей сил 15кН. Изобразите силы, действующие на автомобиль. Определите ускорение, приобретаемое...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
write('a = ');
readln(a);
a1:=a div 100;
a2:=a div 10 mod 10;
a3:=a mod 10;
if (a1 mod 2 = 0)or(a2 mod 2 = 0)or(a3 mod 2 = 0)
then writeln('В числе есть четные цифры')
else writeln('В числе нет четных цифр');
end.
Пример:
a = 519
В числе нет четных цифр