В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Cheburek1112
Cheburek1112
20.09.2020 05:21 •  Информатика

Составьте программу. Сформировать одномерный массив из 7 элементов, где элементы массива целые случайные числа в пределах от 20 до 45. Найти сумму элементов массива. Напечатать сумму и элементы массивав в столбец.

Показать ответ
Ответ:
еренйегер2398
еренйегер2398
25.01.2022 06:35

1 Аполлон - божество солнца, сын Зевса и Лето, а все остальные планеты

2. Флейта - духовный инструмент, а остальные струнные

3. Рикша - это повозка, а остальные название морских судов

4. Тургенев - писатель, а остальные композиторы

5. Нью-Йорк - город, а все остальные столицы

6. бунгало, иглу, шале - это жилье, причем тут осень и зима

7. Нил - река в африке, а остальные в Европе

8. Руслан - название самолета, остальные название авто

9. Торф - минерал, остальные твердые ископаемые

10. Кофе - мужского рода, остальные среднего рода

0,0(0 оценок)
Ответ:
FireGame228
FireGame228
25.01.2022 06:35

ответ:ОБЪЯВЛЕНИЕ МАССИВА

Массивы в Паскале используются двух типов: одномерные и двумерные.

Определение одномерного массива в Паскале звучит так: одномерный массив — это определенное количество элементов, относящихся к одному и тому же типу данных, которые имеют одно имя, и каждый элемент имеет свой индекс — порядковый номер.

Описание массива в Паскале (объявление) и обращение к его элементам происходит следующим образом:

Описание массива в Паскале

Объявление массива

var dlina: array [1..3] of integer;

begin

dlina[1]:=500;  

dlina[2]:=400;  

dlina[3]:=150;

...

dlina — идентификатор (имя) массива;

для объявления используется служебное слово Array (в переводе с англ. «массив» или «набор»);

[1..3] — в квадратных скобках ставится номер (индекс) первого элемента, затем две точки и индекс последнего элемента массива, т.е. по сути, указывается количество элементов; количество элементов массива называется размерностью массива

of integer (с англ. «из целых чисел») — указывает, к какому типу относится массив, of здесь — служебное слово.

 

Объявить размер можно через константу:

размер массива через константу

ИНИЦИАЛИЗАЦИЯ МАССИВА

Кроме того, массив может быть сам константным, т.е. все его элементы в программе заранее определены. Описание такого массива выглядит следующим образом:

const a:array[1..4] of integer = (1, 3, 2, 5);

Заполнение последовательными числами:

заполнение массива

Результат:

A[1] = 8, A[2] = 9, A[3] = 10, ..., A[N] = A[N-1] + 1

Ввод с клавиатуры:

Пример: Рассмотрим, как происходит ввод массива в Паскале:

writeln ('введите кол-во элементов: ');

readln(n); {если кол-во заранее не известно, - запрашиваем его}

for i := 1 to n do begin

  write('a[', i, ']=');

  read(a[i]);

  ...

end;

...

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота