Составьте программу с использованием команды ветвления для решения одной из следующих (выбор осуществляется преподавателем):
1.1. по номеру месяца определить количество дней в нем (в невисокосном году).
1.2. по номеру месяца определить время года.
1.3. по номеру дня недели определить количество занятий.
1.4. по числу лет определить является ли человек школьником, пенсионером и т.п.
1.5. по номеру класса определить в начальной школе, среднем звене или в старших классах обучается ученик.
1.6. по номеру группы определить на каком курсе учится студент.
1.7. по числу текущего месяца определить день недели.
Crt;
const
n = 10;
type
V = array[1..n] of integer;
function Mid(var a: V): double;
var
i, s: integer;
begin
s := 0;
for i := 1 to n do s := s + a[i];
Mid := s / n
end;
var
x: V;
i, j: integer;
m: double;
begin
Randomize;
m := 0;
for i := 1 to 5 do
begin
Writeln('Элементы массива ', i);
for j := 1 to n do
begin
x[i] := Random(100);
Write(x[i]:3)
end;
Writeln;
m := m + Mid(x)
end;
Writeln('Среднее арифметическое пяти массивов равно ', m)
end.
Тестовое решение:
Элементы массива 1
95 44 54 86 52 39 28 79 29 43
Элементы массива 2
75 55 26 22 12 93 34 60 34 42
Элементы массива 3
55 80 50 54 52 46 85 47 11 86
Элементы массива 4
33 35 5 64 36 66 76 55 24 43
Элементы массива 5
31 63 66 11 88 4 31 99 28 39
Среднее арифметическое пяти массивов равно 76.6
Объяснение:
program Randomizer;
const
RndLimit = 10000;
var
x, SumX : integer;
begin
SumX := 0;
// Коммент: случайное число в паскале всегда генерируется от 0 до заданного но нам необходимо от 1000, поэтому в цикле repeat...until оно будет генерироваться до тех пор, пока не станет > 999
Repeat x := Random(RndLimit) until x > 999;
writeln ('Random X= ', x);
SumX := SumX + (x div 1000) + (x mod 1000 div 100) + (x mod 1000 mod 100 div 10) + (x mod 1000 mod 100 mod 10);
writeln ('Sum = ', SumX);
end.
запускаем
Free Pascal Compiler version 2.6.2-8 [2014/01/22] for x86_64
Copyright (c) 1993-2012 by Florian Klaempfl and others
Target OS: Linux for x86-64
Compiling main.pas
Linking a.out
21 lines compiled, 0.1 sec
Random X= 5488
Sum = 25