В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Составьте программу с использованием цикла с ПОСТУСЛОВИЕМ для решения следующей задачи: начав тренировки, спортсмен в первый день пробежал N км. Каждый день он увеличивал дневную норму на P% нормы предыдущего дня. Через сколько дней его суммарный путь превысит S км.

Показать ответ
Ответ:
бэтти56781
бэтти56781
28.01.2021 08:37
Var
    s: string;
    a, b: integer;
begin
    readln(s);
    if s[1] = 'x' then begin
        a := StrToInt(s[3]);
        b := StrToInt(s[5]);
        if s[2] = '-' then a := -a;
        writeln(b - a);
    end
    else if s[3] = 'x' then begin
        a := StrToInt(s[1]);
        b := StrToInt(s[5]);
        if s[2] = '-' then begin
            a := -a;
            b := -b;
        end;
        writeln(b - a);
    end
    else if s[5] = 'x' then begin
        a := StrToInt(s[1]);
        b := StrToInt(s[3]);
        if s[2] = '-' then
            b := -b;
        writeln(a + b);
    end
end.

учтите что никакой защиты от дурака или неверного ввода
0,0(0 оценок)
Ответ:
Ира2806
Ира2806
09.02.2020 21:45
Надеюсь это то что надо

const
    N = 5;

var
    a: array[1..N] of integer;
    i, iMin: integer;

begin
    writeln('Исходный массив:');
    for i := 1 to N do
    begin
        a[i] := random(100) - 50;
        write(a[i]:4);
    end;
    iMin := 1;{инциируем первым элементом}
    for i := 2 to N do {проверяем все остальные}
        if a[i] < a[iMin] then {новый минимальный}
            iMin := i; {запомнить i}
    writeln; {перейти на новую строку}
    writeln('Минимальный элемент a[', iMin, ']=', a[iMin]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота