В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
zb2004
zb2004
28.07.2022 12:54 •  Информатика

Составьте программу рисования индексов городов в чертежнике (кумир) унеча 243300 плес 155555

Показать ответ
Ответ:
arhipflina
arhipflina
14.09.2020 14:29
Высчитаем необходимый размер памяти для хранения 1 символа. 
В используемом алфавите имеется 256 символов. 256 символов (состояний) можно закодировать таким числом бит, которых достаточно для отображения этого числа состояний. В данном случае это 8 бит (т.к. 1111 1111 = 255, да плюс нулевое состояние, итого 256 возможных состояний). 
Т.е. для хранения 1 символа требуется 8 бит = 1 байт.
Посчитаем количество символов в документе. 
30*70*5 = 2100 * 5 = 10500 символов. 
Для хранения которых потребуется
10500 * 1 = 10500 байт. 
(Он же, если нужно, 10500/1024 = 10,25390625 Кбайт. )
0,0(0 оценок)
Ответ:
ruslan189kalin
ruslan189kalin
20.01.2021 23:55
Const  n = 10;
var  mas :array [1..n] of integer;  i, sum, a, k, sch :integer;
begin
  writeln('Введите массив:');  for i:= 1 to n do    readln(mas[i]);  writeln('Введите число A:');  readln(a);  writeln('Введите число k:');  readln(k);    sum:= 0;  for i:= 1 to n do    if mas[i] mod 2 = 1 then      sum:= sum + mas[i];  writeln('Сумма элементов равна ',sum);    writeln('Индексы, значение элементов которых больше ',a,' :');  for i:= 1 to n do    if mas[i] > a then      write(i,' ');  writeln;    sch:= 0;  for i:= 1 to n do    if mas[i] mod k = 0 then      sch:= 1;  if sch = 1 then    writeln('В массиве есть элементы, кратные ',k)  else    writeln('В массиве нет элементов, кратных ',k);    for i:= 1 to n do    if mas[i] mod 5 = 0 then    begin      mas[i]:= 0;      break;    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота