В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sprotopopov1
sprotopopov1
30.12.2022 01:17 •  Информатика

Составьте программу (полный текст программы) для решения следующей . введите с клавиатуры три числа: а, в, с. если все они четные, то найдите и выведите на экран их сумму. если все они нечетные и a> b> c, то определите и выведите значения наибольшего и наименьшего из чисел. иначе, выведите числа без изменения. фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin s: =a+b+c; writeln('сумма равна ', s); end; if (a mod 2 < > 0) and (b mod 2 < > 0) and (c mod 2 < > 0) and (a> b) and (b> c) then begin writeln('наибольшее число ', a); writeln('наименьшее число ', c); end else writeln('a= ',a,' b= ', b, ' c= ',c);

Показать ответ
Ответ:
jimitapark
jimitapark
13.06.2020 14:05

var 

a,b,c,s:integer;

begin

readln(a,b,c);

 if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then

begin

S:=a+b+c; writeln('сумма равна ', S);

end;

if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then

begin

writeln('наибольшее число ', A);

writeln('наименьшее число ', C);

end;

else

writeln('a= ',a,' b= ', b, ' c= ',c);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота