В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Karamelka3467
Karamelka3467
30.03.2021 03:12 •  Информатика

Составьте программу подсчитывающую сколько раз элемент C[i,i] двухмерного массива C(N,N) встречается в этом массиве

Показать ответ
Ответ:
akena0932
akena0932
12.10.2020 02:09

const n=5;

var k,i,j,count:integer;

c:array[1..n,1..n] of integer;

begin

 readln (k);

count:=0;

for i:=1 to n do

begin

for j:=1 to n do

begin

c[i,j]:=random(100);

write(c[i,j],' ')

end;

writeln;

end;

for i:=1 to n do

for j:=1 to n do

if c[i,j]= c[k,k]

then

count:=count+1;

writeln(count:4);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота