В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lele4
lele4
29.07.2021 12:48 •  Информатика

Составьте программу подсчета строк двухмерного массива А(N,N), в которых имеются два нулевых элемента.

Нужно, чтобы программа запустилась в PascalABC
Очень

Показать ответ
Ответ:
Df77
Df77
22.05.2020 15:08
Const n=8;
var 
a:array[1..n,1..n] of integer;
i,j,k,s,s1,si,dmin,smin:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to n do
  begin
  a[i,j]:=random(50);
  write(a[i,j]:4);
  end;
  writeln;
 end;
write('k = '); readln(k);
s:=0;
for j:=1 to n do s:=s+a[k,j];
writeln('s = ',s);
dmin:=999999; smin:=999999;
for i:=1 to n do
 if i<>k then
  begin
  s1:=0; 
  for j:=1 to n do s1:=s1+a[i,j];
  writeln('s',i,' = ',s1);
  if abs(s1-s)<dmin then begin dmin:=abs(s1-s); smin:=s1; si:=i; end;
  end;
writeln('Номер строки = ',si,', smin = ',smin);
end.

Пример:
Исходный массив:
   9   0  22  40  20  35   2  25
  23  30  22  35  41   0   9  40
   1  15   6  18  43  47  34  33
  26   5   2  45  13  46  40   2
  26  39   7  31   3  43  20   8
  25  15  24   6  10  16   3  25
  47   0  27  35  14  15  36  11
  16  38  14  14  33   7  11  26
k = 5
s = 177
s1 = 153
s2 = 200
s3 = 197
s4 = 179
s6 = 124
s7 = 185
s8 = 159
Номер строки = 4, smin = 179
0,0(0 оценок)
Ответ:
kseniaflrsova72
kseniaflrsova72
14.10.2021 01:28
Var
begin
readln(n);
if n=1 then begin writeln('1 месяц');writeln('кол-во дней');end;
if n=2 then begin writeln('2 месяц');writeln('кол-во дней');end;
if n=3 then begin writeln('3 месяц');writeln('кол-во дней');end;
if n=4 then begin writeln('4 месяц');writeln('кол-во дней');end;
if n=5 then begin writeln('5 месяц');writeln('кол-во дней');end;
if n=6 then begin writeln('6 месяц');writeln('кол-во дней');end;
if n=7 then begin writeln('7 месяц');writeln('кол-во дней');end;
if n=8 then begin writeln('8 месяц');writeln('кол-во дней');end;
И так до 12 раз...
Я не уверен что тебе нужен такой монстр...
В место к примеру 1 месяца пишешь январь...
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота