В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
themac9
themac9
25.09.2020 06:59 •  Информатика

Составьте программу подсчета числа элемента одновременного массива, превосходящих среднее арифметическое элементов данного массива.

Показать ответ
Ответ:
Hi12349
Hi12349
08.10.2020 17:45
Программа написана на PascalABC.NET

// Ниже код:

program element;
var a: array[1..1000] of real;    i, j, c: integer;    b: real;    begin  writeln('Введите число элементов: ');  read(j);    for i:= 1 to j do    begin      read(a[i]);      b:= b + a[i];    end;    b:= b / j;    for i:= 1 to j do    if a[i] > b then inc(c);    writeln;  write('ответ: ', c);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота