В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kghjg
kghjg
15.05.2022 21:12 •  Информатика

Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать).сделайте три варианта программы,используя операторы while,repeat ,for.

Показать ответ
Ответ:
BazikPro
BazikPro
06.10.2020 08:12
Program;
var a,i,sr,k,sum:integer;
k:=0;
sum:=0;
Begin
for i:=1 to 10 do
begin;
read(a);
k:=k+1;
sum:=sum+a;
sr:=sum/k;
end;
write(sr);
End.

Program;
var a,i,k,sum,sr,r:integer;
Begin
k:=0
sum:=0;
r:=0;
repeat
begin;
read(a);
k:=k+1;
sum:=sum+1;
r:=r+1;
until r=10;
sr:=sum/k;
write(sr);
End.

Цикл While  подумай сама,уверен у тебя получится
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота