В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
WhiteMIA131
WhiteMIA131
26.05.2023 03:30 •  Информатика

Составьте программу печати таблицы температур по цельсию от 0 до градусов с шагом в один градус и их эквивалентов по шкале фаренгейта используя для перевода формулу tf=9tc/5+32

Показать ответ
Ответ:
О127
О127
05.07.2020 12:20
var
  max, i: integer;
  
begin
  readln(max);
  for i := 0 to max do
    writeln(i:3, chr(0176), 'C | ', 9 * i / 5 + 32, chr(0176), 'F');
end.

Элементарная домашка... Не знаю, прочтёт ли это кто-нибудь, но...
Считываем верхнюю границу вывода (ибо в условии с ней заминка), а затем в столбик выводим... chr() возвращает символ по коду, а 176 - код градуса
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота