В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nlogvinova14
nlogvinova14
25.06.2020 11:21 •  Информатика

Составьте программу определения наименьшего общего кратного 2 натуральных чисел. на абс паскале

Показать ответ
Ответ:
dimanebutov1
dimanebutov1
31.07.2020 21:56
Program Project2;

{$APPTYPE CONSOLE}

uses
SysUtils;

var
n,m,k,c:integer;

function NOD(x,y:integer):integer;
Begin
If x<>0 then NOD:=NOD(y mod x,x) else NOD:=y;
End;

function NOK(x,y:integer):integer;
Begin
NOK:=(x div NOD (x,y))*y;
end;

begin
writeln('Enter M, N, K');
write('m = ');readln(m);
write('n = ');readln(n);
write('k = ');readln(n);
c:=NOK(k,m);
k:=nok(c,n);
writeln('NOK(M,N,K) = ',k);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота