В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ankavasilenko2
ankavasilenko2
20.04.2022 14:35 •  Информатика

Составьте программу определения наибольшего общего делителя двух натуральных чисел. на абс паскале надо

Показать ответ
Ответ:
pasha268
pasha268
03.10.2020 15:57
Var a,b,NOD:integer;
begin
write('a='); readln(a);
write('b='); readln(b);
while (a<>0)and(b<>0) do
 if a>b then a:=a mod b else b:=b mod a;
NOD:=a+b;
writeln('НОД=',NOD);
end.

Пример:
a=75
b=125
НОД=25
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота