В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
SonyaYT
SonyaYT
22.03.2021 21:25 •  Информатика

Составьте программу определения количества четных цифр в данном целом числе и вывода второй его цифры.

Показать ответ
Ответ:
Lev1223
Lev1223
21.01.2021 23:04

var

 N: integer;

 s: string;

 i,c: byte;

begin

 ReadLn(N);

 Str(N,s);

 c:=0;

 for i:=1 to Length(s) do

   if s[i] in ['0','2','4','6','8'] then

     Inc(c);

   Writeln(s[2]);

 WriteLn(c);

 ReadLn

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота