В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
revernastyn
revernastyn
12.04.2021 20:31 •  Информатика

Составьте программу (оператор цикла) для нахождения суммы по следующей формуле: S= (x*x+x)/a*x (при x от 3 до !​

Показать ответ
Ответ:
dinamur03
dinamur03
10.05.2023 01:34
Код#include <iostream>constexpr double bites_to_megabytes(double a) {    return a / 8388608;}constexpr double megabytes_to_gigabytes(double a) {    return a / 1024;}int main() {    long long a;    short type;    bool is_correct = false;    double answer;    do {        std::cin >> a;        std::cout << "[1] Megabytes \n"                  << "[2] Gigabytes \n"                  << "Convert to [1] or [2]: ";        std::cin >> type;        if (type == 1 or type == 2) {            is_correct = true;        } else {            std::cout << "Meh. Try to type again. \n" << std:: endl;        }    } while (!is_correct);    switch (type) {        case 1:            answer = bites_to_megabytes(a);            break;        case 2:            answer = megabytes_to_gigabytes(bites_to_megabytes(a));            break;    }    std::cout << "An answer of conversion is " << answer << std::endl;    return 0;}
0,0(0 оценок)
Ответ:
Гaяз
Гaяз
08.08.2021 13:19
Как-то так
#include <iostream>
using namespace std;
int main(){    cout << "Vvedute kol-vo ocenok" << endl;
    int n,i,a,Four,Five;    n = i = a = Four = Five = 0;
    cin >> n;
    for (i = 1; i <= n; i++)    {        cin >> a;        if (a == 4){         Four++;}  else if (a == 5)      {         Five++;      }    }    if (Four > Five){   cout << "Four" << endl;} else if (Five > Four)      {   cout << "Five" << endl;      }      else      {         cout << "Equal"<< endl;      }      cout << "Kol-vo 4: " << Four << " Kol-vo 5: " << Five << endl;    return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота