В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
79854246143TATIANA
79854246143TATIANA
18.01.2020 23:58 •  Информатика

Составьте программу нахождения количества делителей числа n (значение n вводится с клавиатуры)

Показать ответ
Ответ:
абдулоахмед1
абдулоахмед1
20.08.2020 06:21
uses crt;
Var x, y, k:integer;
procedure delit;
begin  k:=0;  
writeln('Делители числа ', x, ':');  
for y:=1 to x do  if x mod y=0 then
begin
write( y, ' ');  
k:=k+1
end;  
writeln('Количество делителей числа ', x, ' равно ', k);
end;
begin clrscr;  
writeln ('Введите число: ');  
readln (x);  
delit;  
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота