В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
PolinaSukova2
PolinaSukova2
24.03.2023 19:51 •  Информатика

Составьте программу, находящую количество делителей числа х. число х введите с клавиатуры. (pascal abc (не net))

Показать ответ
Ответ:
Adalet555
Adalet555
07.10.2020 08:32
Var n, i, sum: integer; //Описание переменных Begin //Начло программы writeln ('Введите число'); //Диалог с пользователем readln(n); //Считывание числа sum := n; //Присваивание сумме значение самого числа (само число - уже делитель самого себя) writeln('Делители числа:'); //Диалог с пользователем for i := 1 to n div 2 do //Цикл For от до половины n if (n mod i) = 0 then begin //Если число делится на i, то выводим write(i,' '); sum := sum + i; //К значению суммы прибавляем делитель end; //Конец условного оператора if writeln(n); //Вывод самого числа, т.к. оно тоже делитель writeln('Сумма делителей: ',sum); //Вывод суммы делителей End.
0,0(0 оценок)
Ответ:
slava4В
slava4В
07.10.2020 08:32
Program A;var X,sum,i: integer;beginsum := 0 ;Readln(X);for i:= 1 to X doif (X  mod i = 0) then   sum := sum + 1;Writeln(sum);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота