В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
PavelSahka
PavelSahka
15.07.2020 03:22 •  Информатика

Составьте программу на языке программирования Паскаль, в которой требуется выполнить следующие действия: • Пользователь задает с клавиатуры последовательность из n целых чисел (n также определяется пользователем). Найти среднее арифметическое чисел из этой последовательности.

Показать ответ
Ответ:
elinamar
elinamar
15.10.2020 14:27

var N,x,S,i:integer;

   SR:real;

begin

 writeln ('кол-во чисел в последовательности N=');

 readln (N);

 S:=0;

 for i:=1 to N do

 begin

   read (x);

   S:=S+x;

 end;

 Sr:=S/N;

 Writeln('Sr=',Sr)

end.

Объяснение:

0,0(0 оценок)
Ответ:
MrHelpOnline
MrHelpOnline
15.10.2020 14:27

--- PascalABC.NET 3.6.2 ---

begin

 var N := ReadInteger();

 var S := ReadSeqInteger(N);

 S.Average.Println;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота