В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
саидолим
саидолим
14.02.2023 06:15 •  Информатика

СОСТАВЬТЕ ПРОГРАММУ НА ЯЗЫКЕ ПАСКАЛЬ Составить программу. Коммерсант, имея стартовый капитал k рублей, занялся торговлей, которая ежемесячно увеличивает капитал на p%. Через сколько лет он накопит сумму s, достаточную для покупки собственного магазина?

Показать ответ
Ответ:
Stasonka
Stasonka
04.09.2020 14:55

var

 n,s,p:integer;

 l,k:real;

 

begin

 readln(k);

 readln(p);

 readln(s);

 n:=0;

 repeat

  l:=k*p/100;

  k:=l+k;

  n:=n+1;

 until k > s;

 write(n div 12,'Лет',n mod 12,'Месяцов');

 readln;

end.

взял отсюда: https://studassistent.ru/turbo-pascal/kommersant-imeya-startovyy-kapital-turbo-pascal

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота