В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
LediLizonka
LediLizonka
01.03.2021 05:09 •  Информатика

Составьте программу на языке паскаль для решения . с клавиатуры вводятся 5 действительных чисел. найти сумму всех чисел, больше 5. и произведение всех чисел, меньше 1.

Показать ответ
Ответ:
12309874
12309874
07.10.2020 05:11
Const n =5;
var
  a: array[1..n] of integer;
  i,k,s,p:integer;
begin
s:=0;
p:=1;
for i:=1 to n do
  begin
  readln(a[i]);
  if(a[i] >= 5) then
      s:=s+a[i] else
  if (a[i] <1) then
      p:=p*a[i];
  end;
 writeln('Исходные числа');
for i:=1 to n do
    write(a[i]+ ' ');
writeln;
writeln('Сумма чисел больше 5 : ',s:2);
writeln('Произведение меньше 1 : ',p:2);
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота