В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
stalkeregor344
stalkeregor344
05.05.2020 01:36 •  Информатика

Составьте программу на языке BASIC.
1. Высчитать площадь трапеции если известны высота, верхнее основание и разность между основаниями.
2. Компьютер здоровается с человеком, узнает его имя и. обращаясь по имени, сообщает, что сегодня - выходной.
3. Вычислить площадь треугольника по трем сторонам (формула Герона).
4. Вычислить время падения кирпича в секундах с крыши дома, если известны высота дома в метрах и, ускорение свободного падения

Показать ответ
Ответ:
maltsevaalbina2006
maltsevaalbina2006
02.08.2022 00:38
Функция вычисления арктангенса есть. Остальные можно выразить через арктангенс. Пусть х - число которое вводится в приемное поле калькулятора, у - это то, значение, которое мы выводим в поле ответа калькулятора.
1) arcsin 
if abs(x)<1 then
   y:=arctan(x/sqrt(1-x*x)
   else y:=Pi*x;

2) arccos 
y:=arctan(sqrt(1-x*x)/x);
if x<0 then y:=Pi+y;

3) arctg
y:=arctan(x);

4) arcctg
if x=0 then y:=Pi else y:=arctan(1/x);
if x<0 then y:=Pi+y;

5) n! 
y:=1;
for i:=1 to x do  y:=y*i;

6) %
y:=x/100

Следует при проверке иметь ввиду, что арксинус и арккосинус могут быть только в пределах от -1 до 1. Другие значения вводить нельзя. Или надо добавить проверку на корректность входных данных. 
0,0(0 оценок)
Ответ:
Dariasolne4naya
Dariasolne4naya
17.07.2020 23:37

Первое задание:

1) 3

2) 6

3) 5

Второе задание:

1) 1

2) 3

Третие:

//Язык программирования java

package com.niksonbinsk;

import java.util.ArrayList;

import java.util.Scanner;

public class Main {

   public static void main(String[] args) {

       int space_left = 0;

       int count = 0;

       Scanner s = new Scanner(System.in);

       ArrayList<Integer> str = new ArrayList<>();

       while(space_left != 30){

           System.out.println("Enter next num:");

           str.add(s.nextInt());

           space_left++;

       }

       for(int i =0;i<30;i++){

           if(str.get(i) % 2 == 0){

               count++;

           }

       }

       System.out.println(count);

   }

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота