В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
камил486
камил486
25.07.2022 02:56 •  Информатика

Составьте программу на вычисление кинетической энергии, если известны масса ученика и его скорость. При вводе значений 0 для переменных массы и скорости, программа выводит сообщение «Введите корректные значения». Вывод производить в label2.

Показать ответ
Ответ:
dariavasilevskayaa
dariavasilevskayaa
01.03.2023 03:03

n = int(input())  # присваиваем n - кол-во чисел

z = 0  # z - сумма всех чисел (изначально она = 0)

a = []  # a - массив состоящий из n чисел

for i in range(n):  # делаем цикл для заполнения a

   a.append(int(input()))  # заполняем a

   z = z+a[i]  # так же считаем сумму всех чисел из a

x = z / len(a)   # x - ср.ар. n чисел

l =abs(a[0]-x)  # создаем n для того чтобы найти самое близкое к x число

m = 1  # создаем m для того чтобы найти номер самого близкого числа

for i in range(1,len(a)):  # делаем цикл для нахождения m и n

   if abs(a[i]-x)<l:  # если число ближе к x чем число под номером n

       l = abs(a[i]-x)  # то присваиваем l - это число

       m = i + 1  # а m - номер этого числа

print(m) # выводим номер числа

Объяснение:

0,0(0 оценок)
Ответ:
rusakovwn
rusakovwn
05.12.2021 12:46

Python 3.7.2

x = int(input(), base = 10)

k3 = k5 = 0

for digit in map(int, list(str(x))):

   if digit is 3: k3 += 1

   elif digit is 5: k5 += 1  

#Что бы не городить огромные условные конструкции,

#Мы просто "выключим" программу при кривом вводе

if k3 == k5 == 0: raise RuntimeError('bad input')

#Если введённое число не имеет нужных цифр - вылетаем с ошибкой Runtime error и сообщаем об этом

print(f'цифр 5 больше, счётчики: k3: {k3}, k5: {k5}' if (k5 > k3) else f'цифр 3 больше, счётчики: k3: {k3}, k5: {k5}')

y = int('5'*k5 + '3'*k3)

y1 = y - 7

#Это можно засунуть в print(), но раз уж надо...

print(x, y, y1, end = '\n')

Объяснение:

На скриншотах представлены исходный код программы в рабочем виде, без поломанных отступов, а так же результат работы для предложенных входных данных. Если сильно надо программу просто скопировать, сдать и забыть, а отсюда не копируется - попросите в комментариях, я залью это на какой нибудь сервис типа pastebin.


Цикл for.Python С экрана вводится натуральное число произвольной длины. Назовите его x. Определите,
Цикл for.Python С экрана вводится натуральное число произвольной длины. Назовите его x. Определите,
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота