Составьте программу на питон Длина Московской кольцевой автомобильной дороги —109 километров. Байкер Вася стартует с первого километра МКАД и едет со скоростью V километров в час. На какой отметке он остановится через T часов?
Первая строка входного файла INPUT.TXT содержит два целых числа V и T – скорость (км/ч) и время поездки в часах соответственно. Числа разделены пробелом. Если V>0, то Вася движется в положительном направлении по МКАД, если же значение V<0, то в отрицательном. Ограничения: |V| ≤ 1000, 0 ≤ T ≤ 1000.
В выходной файл OUTPUT.TXT выведите целое число от 1 до 109 – километр МКАД, на котором остановится Вася.
Объяснение:
Есть ошибки. Не будет компилироваться. Будет ошибка выполнения в первой программе для отрицательных значений x.
Жирным выделены строчки, где есть ошибки.
1) Описание переменных следует писать так
Var x, y: real;
2) Пропущена точка с запятой
y:= sqrt(x);
3) Корень с отрицательного числа
y:= sqrt(x)
4) Во второй программе в объявлении переменных
Var x, y: real;
5) Пропущены знаки операций
y :=3 * x / (8 - x)
6) во второй программе, если знаменатель == 0, то после вывода - решений нет, следует вывод не инициализированного значения у.
Вывод значения y надо перенести выше, после вычисления y.
Program nl;
Var: x,y; real;
Begin
Readln (x);
if x >= 0 then
y:= x*x
Else
y:= sqrt(x)
Writeln(y);
End.
Program nl;
Var: x,y;real;
Begin
Readln(x);
if (8-x)<>0 then
y:=3x/8-x
Else
Writeln('решений нет');
Writeln(y);
End.
Так лучше будет (по возможности исправлено)
{ Тело первой программы }
Var x, y: real;
Begin
Write ('Input x: ');
Readln(x);
if x >= 0 then
y := x * x
Else
y := sqrt(abs(x));
Writeln('y: ', y: 10: 3);
Readln(); // удерживаем консоль
End.
{ Тело второй программы }
Var x, y: real;
Begin
Write ('Input x: ');
Readln(x);
if (8-x) <> 0 then
bеgin
y:=3*x/(8-x);
Writeln(' y=', y: 10: 2);
end
Else
Writeln('решений нет');
Readln(); // удерживаем консоль
End.
a = float(input("Введите длину стороны квадрата >> "))
if a<=0:
print ("Нельзя вводить отрицательные и нулевые значения")
else:
s = a*a
p = 4*a
print ('S = ',s,'; P = ', p)
Объяснение:
Первая строка - вводим длину стороны. Это может быть вещественное число, например 2.2
Если ввести отрицательное число, то задача не имеет смысла, так что делаем проверку на отрицательность и равенство 0 и сообщаем о том, что такие числа вводить нельзя. Это делает 2-я и третья строки программы.
Если введено положительное число, то подсчитываем площадь S и периметр P квадрата.
Выводим полученные данные на печать.
Приложен пример работы программы (Python 3)