В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
BREYKER
BREYKER
03.03.2021 20:26 •  Информатика

Составьте программу на паскале, которая вводит 2 целых числа m и n и печатает все целые числа между m и n, делящиеся на 7, включая и сами эти числа. замечание: программа должна учитывать, что заранее не известно, какое из чисел m или n больше другого.

Показать ответ
Ответ:
svinka03
svinka03
09.10.2020 03:43

var

   N, M, prov: longint;

begin

   readln(N);

   readln(M);

   if N < M then

   begin

       prov := N;

       while prov <= M do

       begin

           if prov mod 7 = 0 then

               writeln(prov);

           inc(prov);

       end;

   end

   else  

   begin

       prov := M;

       while prov <= N do

       begin

           if prov mod 7 = 0 then

               writeln(prov);

           inc(prov);

       end;

   end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота