В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
andreytolstik
andreytolstik
03.01.2022 16:43 •  Информатика

Составьте программу на паскале для пяти чисел по убыванию и нахождение их суммы

Показать ответ
Ответ:
llerochka1
llerochka1
08.10.2020 12:32
Var
  A: array [1 .. 5] of real;
  i, j: byte;
  sum, tmp: real;

begin
  sum := 0;

  { Заполнение массива }
  for i := 1 to 5 do
  begin
    write('A[', i, '] = ');
    readln(A[i]);
    sum := sum + A[i]; // подсчет суммы
  end;
  writeln(#13 + 'Сумма элементов = ', sum);

  { Сортировка по убыванию }
  for i := 1 to 4 do
    for j := i + 1 to 5 do
      if A[i] < A[j] then
      begin
        tmp := A[i];
        A[i] := A[j];
        A[j] := tmp;
      end;

  { Вывод }
  writeln('Отсортированный массив: ');
  for i := 1 to 5 do
    write(' ', A[i]);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота