Составьте программу на Pascal используя блок схему:
где A= 10000 рыб а прирост 10%
В цикле будет:
1) Запас А:= А + 0.10*А – В
2) Прибавить год N:=N+1
Используем Цикл с заданным условием окончания работы (цикл-ДО, цикл с постусловием).
До А < С все будет работаеть. Потом план выполняться уже не будет, т.к. запас рыб не восполнится.
from itertools import product
i = open('input.txt', 'r')
o = open('output.txt', 'w+')
l = int(i.
alpha = "245"
d = []
for s in product(alpha, repeat=l):
d.append([" ".join(
for q in d[1: ]:
s = " ".join(q)
if int(s.count('2')) > 2:
continue
o.write(" ".join(q) + '\n')
i.close()
o.close()
код к : «перевод кода с питона на паскаль»
var
n,c,i,ost,b,t,d: integer;
a,k: string;
begin
readln(n);
c: =1;
for i: =1 to n do
c: =c*3;
c: =c-1;
for i: =1 to c do
begin
k: ='';
b: =i;
t: =0;
while b> 0 do
begin
ost: =b mod 3;
if ost=0 then inc(t);
d: =(-sqr(ost)+5*ost+4)div 2;
str(d,a);
k: =a+k;
b: =b div 3;
end;
while length(k)do
begin
k: ='2'+k;
inc(t);
end;
if t< =2 then writeln(k);
end;
end.