В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
1602qaz
1602qaz
08.12.2022 03:25 •  Информатика

Составьте программу, котораясоставьте программу, которая заполняет массив а[1,,10 ] случайными числами в диапазоне от 0 до 10 , затем первый элемент меняет местами с максимальным элементом. выведите на экран исходный и полученный массивы.

Показать ответ
Ответ:
RANDOM328
RANDOM328
26.06.2020 08:26
uses crt;
const N=10;
var a:array [1..N] of integer;
    x,pos,max:integer;
begin
     randomize;
     for x:=1 to N do
     begin
         a[x]:=random(11);
         writeln('a[',x,']:',a[x]);
     end;
     max:=1;
     for x:=1 to N do
          if a[x]>a[max] then max:=x;
     pos:=a[1];
     a[1]:=a[max];
     a[max]:=pos;
     writeln;
     for x:=1 to N do
         writeln('a[',x,']:',a[x]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота