В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
azamatyusupov
azamatyusupov
17.06.2022 17:24 •  Информатика

Составьте программу, которая запрашивает t-время в часах(0,3,69,12,15,18,21,24),


Составьте программу, которая запрашивает t-время в часах(0,3,69,12,15,18,21,24),

Показать ответ
Ответ:
HeeeeelpPlz
HeeeeelpPlz
03.04.2021 11:20

1.Какую задачу решает технология flex-box?

Вот представим, что мы сделали сайт, однако этот сайт на каком-то другом устройстве будет смотреться не так как надо. Нам придется или делать макет для каждого устройства, или использовать flex box

2.Какие осы вы знаете?

Главную и поперечную. Главная ось проходит по направлению расположении элементов, то есть не обязательно что бы главной осью была только вертикальная линия, все зависит от расположения элемента.

3.Какое направление по умолчанию имеет главная ось?

Вертикальное, с лева на право

4.Какое направление по умолчанию имеет поперечная ось?

С верху вниз

5.По умолчанию какие размеры имеет flex элемент?

Зависит от содержимого (?)

6.Что такое flex контейнер?

Родительский блок, который включает в себя flex элементы и содержат свойства, предназначенные для описания принципов работы flex элементов.

7.Что делает свойство flex-direction?

Свойство, которое задает направление главной оси

8.Какие значения у свойства flex-direction вы знаете?

Row, row-reverse, column, column-reverse. Первое это значение по умолчанию, то есть с лева на право. А column с верху вниз. Соответственно reverse просто зеркалит

9. Значение space-evendly?

Flex элементы размещены на одинаковое расстояние между собой

10.Чем занимается свойство justify-content?

Задает выравнивание

11.Что делает свойство order?

Устанавливает порядок следование flex элементов относительно друг друга

12.Какое значение по умолчанию имеет свойство order?

0

13.Что нужно написать, чтобы поменять местами 1 и 5 элемент?

В первый див пишем

order:1

А в пятый:

order: -5;

14. Что происходит если элементы не помещаются по ширине?

Они выходят за рамки (дозволенного пх)

15. Какие значения свойства flex-wrap вы знаете?

1) no-wrap: не переносить

2) wrap: переносить

3) wrap-reverse: на следующую строчку переносятся элементы, которые были в начале контейнера

16. Чем занимается свойство align-items?

Задает выравнивание элементов относительно поперечной оси

17. Какое значение по умолчанию у свойства align-items?

stretch: при котором flex-элементы растягиваются по всей высот или по всей ширине flex-контейнера. То есть с этим значением flex элементы занимают все доступное место(пространство) в контейнере

18. В чем различие align-items и align-content?

Отличие align-content от align-items в том, что свойство влияет на ряды, а не на отдельные элементы.

19. Какое свойство и значение обязательно для работы flex-box?

display: flex;  

20. Как переместить на следующий ряд, определенный flex-items не изменяя размера flex-box?

С свойства flex-wrap

21. Что делает свойство flex-flow?

свойства flex-wrap и flex-direction можно задать с этого свойства. Как аналогию можно взять border, где я могу конечно задать отдельно толщину, цвет и так далее, но этим свойством я делаю это все одновременно

22. Что делает свойство flex-grow?

позволяет указать коэффициент увеличения элемента относительно свободного пространства внутри флекс-контейнера.

23. Что делает свойство align-self?

работает точно так же, как и align-items только задает только для одного элемента. Пишется к самому элементу

24. Как называются точки начала осей и конца осей?

Main start/main end, Cross start/cross end

25. Что делает свойство flex-basis?

задает базовую ширину флекс-элемента, относительно которой будет происходить растяжение

Объяснение:

0,0(0 оценок)
Ответ:
domaris246
domaris246
17.04.2021 17:14

Итак, целевой язык - C++. Это значит мы - радостные обладатели технологии потоков, с коей мы будем производить весь ввод/вывод как при работе с файлами, так и при работе со стандартным вводом/выводом (консолью).

Ну а раз уж мы работаем с потоками, то будем делать это красивенько: создадим класс-обёртку для потока ввода, цель которого - поиск в этом потоке цитат и отправка их на поток вывода (который мы передаём).

[!] Стоит отметить, что по заданию не сказано, что есть разница между ' и ". Поэтому будем считать их одинаковыми.

[!] Внимание! Рядом с исполняемым файлом надо создать текстовый файл data.txt c текстом и цитатами.

Код

С++11

#include <iostream>#include <fstream>using std::cout;class QuotesFinder {    std::istream &in_stream;    bool is_it_in_quote = false;public:    QuotesFinder() = delete;    QuotesFinder(QuotesFinder&&) = default;    QuotesFinder(QuotesFinder const&) = default;    explicit QuotesFinder(std::istream &is) : in_stream(is) {}    [[nodiscard]]    bool eof() const {        return in_stream.eof();    }    // Вот тут происходит вся магия    QuotesFinder& operator >> (std::ostream& out_stream) {        char buffer;        in_stream.get(buffer); //Получаем очередной символ из потока        if (buffer == '\"' || buffer == '\'') {            if (is_it_in_quote) {                is_it_in_quote = false;                out_stream << buffer;                out_stream << "\n";                return *this;            }            is_it_in_quote = true;        }        if (is_it_in_quote) {            out_stream << buffer;        }        return *this;    }};int main() {    std::ifstream file("data.txt");  // Открываем файл    if (!file.is_open()) {        cout << "File is not exits!";        return 1;    }    QuotesFinder finder(file);  // Создаём обёртку из файлового потока    while (!finder.eof()) // Пока не достигли конца потока        finder >> cout; // переправляем очередной кусок информации в поток вывода}
Написать программу на С++. Задача - Считать текст из файла и вывести на экран только цитаты, т. е. п
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота