В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
atitova644
atitova644
24.01.2021 17:03 •  Информатика

Составьте программу, которая заполняет массив б(1..10) случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с чётными значениями пример вывода исходный массив : 10 2 4 1 3 5 7 8 количество пар чётных элементов = 2

Показать ответ
Ответ:
smelinkova
smelinkova
26.05.2020 12:36

#include <iostream>

 

int main()

{

 int b[10];

 for(int i=0;i<10;i++)

 { 

  b[i]=rand()%10+1;

 }

 int a=0;

 for(int i=0;i<9;i++)

 {

  if(b[i]%2==0 && b[i+1]%2==0)

   a++;

 }

std::cout<<"Чётных пар: "<<a<<std::endl;

system("PAUSE");

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота