Составьте программу, которая выводит на экран различные в зависимости от введенного времени. договоримся, что утро длится с 8 до 12 часов, день – с 12 до 17 часов, вечер – с 17 до 23 часов и ночь – все остальное время. program privet; var x: real; begin writeln('который час? '); read(x); if then writeln('доброе утро! '); if then writeln('добрый день! '); if then writeln('добрый вечер! '); if then writeln('доброй ночи! ') else writeln('введенное число не является временем ' ) ; end.
PROGRAM
Privet;
VAR
x:
real;
BEGIN
writeln(
'Который час?'); read(x);
if
x>
24 then
writeln(
'Введенное число не является временем ' )
else
begin
if
(x>=
8) and (x<12) then writeln('Доброе утро!');
if
(x>=
12) and (x<17) then writeln('Добрый день!');
if
(x>=
17) and (x<23) then writeln('Добрый вечер!');
if
(x>=
23) or (x<8) then writeln('Доброй ночи!');
end
;
end
.