В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Angeloc2567
Angeloc2567
21.04.2022 00:12 •  Информатика

Составьте программу которая вычисляет сумму натуральных чисел на отрезке ( 5, 10 ) с оператора while

Показать ответ
Ответ:
smoke228322
smoke228322
02.10.2020 10:23
Var n, o: integer;
begin
n:=5;
while (n<>11) do
begin
o:=o+n;
n:=n+1
end;
writeln(o)
end. 
0,0(0 оценок)
Ответ:
AdelkaTiVi
AdelkaTiVi
02.10.2020 10:23
#include <conio.h>
#include <iostream>
#include <locale.h>

using namespace std;

int main()
{
setlocale(0,"");
int x_min,x_max;
int Sum;
cout<<"Введите начало отрезка\n";
cin>>x_min;
cout<<"Введите конец отрезка\n";
cin>>x_max;

int temp=x_min;

if(x_min>x_max) //проверяем что бы минимальный элемент не был больше максимального
{
int temp;//буфер
temp=x_min;
x_min=x_max;
x_max=temp;
}

while(x_min<=x_max)
{
Sum+=x_min;
++x_min;
}

cout<<"Сумма натуральных эментов на отрезке ("<<temp<<","<<x_max<<") = "<<Sum<<endl;
return 0;
}

Программа вычисляет отрезок любого элемента и делает проверку на правильность ввода
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота