В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
pasatnuk
pasatnuk
30.10.2020 22:43 •  Информатика

Составьте программу которая вычесляет значение выражения k=x³-4xy(x+y²) ИВТ​

Показать ответ
Ответ:
Вэшоу
Вэшоу
04.04.2021 12:17

#include <iostream>

using namespace std;

// функция с алгоритмом двоичного поиска  

int Search_Binary (int arr[], int left, int right, int key)

{

int midd = 0;

while (1)

{

 midd = (left + right) / 2;

 

 if (key < arr[midd])       // если искомое меньше значения в ячейке

  right = midd - 1;      // смещаем правую границу поиска

 else if (key > arr[midd])  // если искомое больше значения в ячейке

  left = midd + 1;    // смещаем левую границу поиска

 else                       // иначе (значения равны)

  return midd;           // функция возвращает индекс ячейки

 if (left > right)          // если границы сомкнулись  

  return -1;

}

}

int main()

{

setlocale (LC_ALL, "rus");

 

const int SIZE = 12;

int array[SIZE] = {};

int key = 0;

int index = 0; // индекс ячейки с искомым значением

for (int i = 0; i < SIZE; i++) // заполняем и показываем массив

{

 array[i] = i + 1;

 cout << array[i] << " | ";

}

 

cout << "\n\nВведите любое число: ";

cin >> key;

 

index = Search_Binary (array, 0, SIZE, key);

if (index >= 0)  

 cout << "Указанное число находится в ячейке с индексом: " << index << "\n\n";

else

 cout << "В массиве нет такого числа!\n\n";

 

return 0;

}

0,0(0 оценок)
Ответ:
1234567891155
1234567891155
24.12.2022 12:54

12

Объяснение:

Импликация A → B неверна только в том случае, когда посылка A истинна, а следствие B ложно.

Значит, не должно найтись таких x, что ¬ДЕЛ(x, 18) (то есть, x не делится на 18), (¬ДЕЛ(x, A) → ¬ДЕЛ(x, 12)) ложно.

¬ДЕЛ(x, A) → ¬ДЕЛ(x, 12) ложно, если ¬ДЕЛ(x, A) (x не делится на A) и неверно, что ¬ДЕЛ(x, 12) (то есть, если x делится на 12).

Собираем вместе:

Не должно найтись таких x, для которых одновременно x не делится на 18, x не делится на A и x делится на 12.

Если x делится на 12 = 6 * 2 и не делится на 18 = 6 * 3, то оно точно делится на 12, и не факт, что делится на что-то большее. Значит, максимально возможное значение A - 12.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота