В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Kurban9595
Kurban9595
10.05.2022 16:26 •  Информатика

Составьте программу которая позволяет закодировать строку путем замены всех звонких согласных на соответствующие глухие, а глухих на звонкие

Показать ответ
Ответ:
nyutadavdova200
nyutadavdova200
25.06.2020 07:29
const
  s: array [1..6] of char= ('б','в','г','д','ж','з');
  d: array [1..6] of char= ('п','ф','к','т','ш','с');

var
  c: string;
  i,j: integer;

begin
  readln(c);
  for i:= 1 to length(c) do
    for j:= 1 to 6 do
      if d[j]=c[i] then c[i]:= s[j]
      else
        if s[j]=c[i] then c[i]:= d[j];
  writeln(c)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота