Составьте программу, которая по выбору пользователя возводит введенное с клавиатуры целое число в квадрат, определяет его абсолютную величину или извлекает квадратный корень числа. в программе следует предусмотреть вывод сообщений об ошибке, если пользователь попытается извлечь квадратный корень из отрицательного числа. использовать стандартные функции abs, sqr, sqrt.
пы.сы.составить в pascal
Простая вставка таблицы
Из ленточного меню выберите пункт «Вставка», область «Таблицы». Нажмите на стрелочку под кнопкой «Таблица».
Из выпадающего списка выделением отметьте желаемое количество строк и столбцов в таблице. В процессе выделения, в вашем документе появится превью макета. Чтобы вставить тот или иной вариант таблицы просто нажмите левой клавишей мыши в крайней выбранной вами ячейке.
Вставка таблицы Word
Кликнув на любую из ячеек в созданной таблице, в ленточном меню добавится пункт «Конструктор», в котором можно удобно поменять дизайн таблицы, выбрав тот или иной стиль оформления, а также задать те или иные значения в области «Параметры стилей таблиц», например, добавить или удалить строку заголовка и строку итогов.
Кроме того, используя контекстное меню по нажатию правой клавиши мыши в области таблицы, можно выбрать пункт «Свойства таблицы» и в открывшемся окне отрегулировать те или иные значения. Установив же курсор в любую из ячеек, можно набирать в ней текст или цифры.
Объединение ячеек
Если вам необходимо объединить несколько ячеек в одну, например, в строке заголовка, то выделите соответствующие ячейки, используя мышь. В ленточном меню выберите пункт «Макет» и в области «Объединение» выберите опцию «Объединить ячейки».
Объединить ячейки таблицы Word
В этой же области можно также разделять ранее объединенные ячейки, а при желании можно разделить одну таблицу на несколько составляющих.
Выделение таблицы
Если вы хотите выделить всю таблицу, например, для ее копирования, перемещения или удаления, то поместить курсор в любую из ячеек, а из ленточного меню в пункте «Макет» в области «Таблица» нажмите кнопку «Выделить» и из выпадающего списка значение «Выделить таблицу». Аналогичным образом можно выделить ячейку, строку или столбец.
Более простой для выделения всей таблицы целиком – это нажать на специальную пиктограмму в правом верхнем углу над таблицей. Эта пиктограмма в виде четырех стрелок в разные стороны появляется при простом наведении курсора на таблицу, а также отображается всегда при работе с элементами таблицы.
Для выделения строки в таблице можно также использовать только курсор мыши – поместите его слева напротив строки для выделения. Стрелка курсора развернется вправо, после чего просто кликнете левой клавишей мыши. Для выделения столбца – поместите курсор мыши на границу верхней ячейки желаемого столбца – курсор должен принять вид черной стрелочки, повернутой вниз, после чего кликните мышью.
Превращаем текст в таблицу
Текстовый редактор Word позволяет преобразовывать готовый текст в таблицу. Для этого соответствующее содержимое должно быть разделено между собой табуляцией, либо символом точка с запятой (;).
Просто выделите набранный текст, в ленточном меню в пункте «Вставка» из области «Таблицы» кликните на кнопку «Таблица» и выберите значение «Преобразовать в таблицу».
Преобразовать текст в таблицу word
В открывшемся диалоговом меню убедитесь, что количество столбцов и строк соответствует выбранной области, при необходимости отрегулируйте значения. В этом же окне в области «Разделитель» убедитесь, что выбранное значение соответствует вашему примеру (если отделяли точками с запятой, то и здесь должен быть отмечен аналогичный пункт). После чего нажмите Ок.
Добавление строк и столбцов
Чтобы добавить новую строку в существующую таблицу, поместите курсор мыши по левому краю таблицы между теми строками, где необходимо добавить новую. Должен отобразиться круглый элемент со знаком плюсика, а граница между двумя строками будет выделена. По нажатию на знак с плюсиком в выбранном месте добавится пустая строка.
Добавить строку в таблице Word
Аналогичным образом можно вставлять и новые столбцы, помещая курсор мыши в области над таблицей между конкретными столбцами. Должен появиться аналогичный элемент с плюсиком.
Кроме того, добавлять строки и столбцы в таблицу можно через ленточное меню в пункте «Макет» в области «Строки и столбцы». Либо же используя контекстное меню и пункт «Вставить» с выбором конкретного значения – что и куда.
Вставить строки и столбцы в таблицу Word
Изменение границ и цвета
Если выбранный ранее стиль таблицы нас не совсем устраивает, мы можем вернуться в уже знакомую нам область ленточного меню «Конструктор». Здесь в области «Обрамление» можно изменить стиль краев как по контуру, так и внутри таблицы между ячейками. Используя элемент «Раскраска границ» можно дополнительно указать ширину и цвет для последующей раскраски, а в дальнейшем вручную изменить внешний вид краев там, где это требуется.
Изменить границы таблицы Word
Наконец, если вы хотите изменить цвет ячеек, то в том же пункте ленточного меню «Конструктор» нажимаем на кнопку «Заливка» и выбираем конкретный цвет, которым должны быть заполнены выделенные ячейки.
Изменение цвета таблицы Word
Объяснение:
#include <iostream>
#include <vector>
using namespace std;
void srez(vector<int> arr, int x, int y, int z = 1) {
for (int i = y; i >= x; i -= z) {
cout << arr[i] << ' ';
}
cout << '\n';
}
int main() {
int n;
cin >> n;
vector<int> arr(n);
for (int i = 0; i < n; ++i) cin >> arr[i];
int x, y, z;
cin >> x >> y >> z;
srez(arr, x, y);
srez(arr, x, y, z);
return 0;
}
Писал код сам, тоже по этой задаче С++