В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
макс3033
макс3033
20.07.2020 14:52 •  Информатика

Составьте программу которая осуществляет ввод в массив с клавиатуры 7 целых чисел и заменяет отрицательные на -1

Показать ответ
Ответ:
lol1049
lol1049
07.08.2020 19:25
Var a:array[1..7] of integer; i:integer; n1:real;
begin
writeln('Введите 7 целых чисел');
for i:=1 to 7 do
begin
repeat
read(n1);
if (n1<>round(n1)) then  writeln('Необходимо целое число');
until (n1=round(n1));
a[i]:=round(n1);
end;
for i:=1 to 7 do
begin
if a[i]<0 then a[i]:=-1;
end;
writeln('Полученный массив:');
for i:=1 to 7 do
write(a[i]:5);
writeln('');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота