В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
belevich031197
belevich031197
04.01.2020 00:19 •  Информатика

Составьте программу, которая определяет, является ли данное натуральное число простым, и выводит на экран соответствующее сообщение: «да» либо «нет».

Показать ответ
Ответ:
Рубик11
Рубик11
06.06.2020 21:21

program xxx;

var k, d, n : integer;

      pr : boolean;

begin

  writeln('Введите число k=');

  readln(k);

  d:=2;

  n:= k div 2;

  pr:=false;

  while (d<=n) and not(pr) do

     if k mod d = o then pr:=true else d:=d+1;

  if pr then writeln (k, '- нет, число не простое') else writeln (k, ' да,число простое');

   readln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота