Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
irinakholod
26.10.2020 10:22 •
Информатика
Составьте программу которая определяет сколько слагаемых должно быть в сумме 1+2+3+4+ чтобы сумма оказалась: больше заданного числа n
Показать ответ
Ответ:
SKARP17868
02.10.2020 22:46
Var
n,i : Integer;
Begin
Readln(n);
i:=1;
While (i+1)*i div 2<=n do Inc(i);
Writeln(i);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Алинаfox11
05.03.2022 00:18
Чему равно в пятеричной системе счисления деление чисел 432 и 12...
vlada365
28.09.2022 19:30
3. вычислить значения выражения: 3*7 div 2 mod 7/3 – trunс (0.89) 10 + trunc(3 + 11 / 3) - round ((10 + 3) / 3) 3 10 – round (3 + 11 / 3) - trunc ((10 + 3) / 3)...
tigranchik111111
02.11.2022 22:11
Волынить перевести на летературный язык...
Oksana321
02.11.2022 22:11
Какие музыкальные произведениясозданы по сказкам пушкина...
xodocovp0a3a7
02.11.2022 22:11
На самостоятельной работе по надо было решить примеры и . решили примеры 21 человек , а 18 человек. определите, сколько человек выполнили полностью, если всего в классе 25...
daniexalmera
02.11.2022 22:11
Если синус квадрат альфа +косинус квадрат альфа будет равен единице, то куда деть коэффициенты при синусе и косинусе. например: 2sin квадрат альфа плюс 3соs квадрат альфа?...
uzerklepa
02.11.2022 22:11
Дан массив целых чисел из 12 элементов. найти количество элементов массива являющихся кратными трем и пяти....
karolsevilla384
02.11.2022 22:11
Написать сочинение вообще на нужно, но сейчас и на подойдет! рассказать про свой город, какие улици например, соседи, что тебя окружает? можно не прям точно все описывать,...
tsibin1982
02.11.2022 22:11
Имеются 100 дискеток и 100 этикеток,раскрашенные в два цвета. дубль это дискета,к которой приклеена этикетка того же цвета. докажите,что можно добиться того, что все дубли...
rama13534
02.11.2022 22:11
Запиши родственные слова, которые приводит в.и. даль в словарной статье. какое из них сейчас редко употребляется? друг, дружелюбие, дружище, дружеский, дружный, дружба, дружество,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
n,i : Integer;
Begin
Readln(n);
i:=1;
While (i+1)*i div 2<=n do Inc(i);
Writeln(i);
end.